Degraded performance on Incoming and Outgoing emails.

Incident Report for Titan Mail

Resolved

This incident has been resolved.
Posted Jan 24, 2023 - 19:37 UTC

Investigating

We are currently investigating this issue.
Posted Jan 24, 2023 - 18:58 UTC
This incident affected: Outgoing Mail Delivery and Titan Client (Incoming Mail).