Titan clients facing outages

Incident Report for Titan Mail

Resolved

This incident has been resolved.
Posted Jan 24, 2023 - 17:53 UTC

Update

We are continuing to investigate this issue.
Posted Jan 24, 2023 - 16:19 UTC

Investigating

We are currently investigating this issue.
Posted Jan 24, 2023 - 16:17 UTC
This incident affected: Titan Client (Mail Send, Login, Incoming Mail) and Calendar, Contacts, Admin Panel, Partner APIs, Partner Webhooks.