Server Outage
Incident Report for Titan Mail
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 11:26 UTC
Update
We are continuing to investigate this issue.
Posted Apr 29, 2021 - 10:47 UTC
Investigating
We are currently investigating this issue.
Posted Apr 29, 2021 - 10:36 UTC
This incident affected: Incoming Mail Delivery, Outgoing Mail Delivery, and POP/IMAP.