Login and Sending issue from Titan Clients

Incident Report for Titan Mail

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 08:26 UTC

Investigating

The issue happened due to a congestion issue in our gateway service.
Posted Apr 03, 2026 - 07:32 UTC
This incident affected: Titan Client (Mail Send).