Degraded performance on incoming emails
Incident Report for Titan Mail
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 19:01 UTC
Identified
We have observed a delay in processing the incoming emails for Titan accounts. Our team is actively working on resolving the issue.
Posted Nov 13, 2023 - 16:44 UTC
This incident affected: Incoming Mail Delivery.