Titan mail login partially impacted
Incident Report for Titan Mail
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 16:26 UTC
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 15:43 UTC
This incident affected: Titan Client (Login).