Server outage
Incident Report for Titan Mail
Resolved
Our operation team found the issue and resolved it.
Posted Apr 09, 2021 - 22:30 UTC
Update
The issue has been fixed.
Posted Apr 09, 2021 - 22:28 UTC
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 22:27 UTC
Investigating
We are experiencing a server outage, this is being investigated currently
Posted Apr 09, 2021 - 22:04 UTC
This incident affected: Incoming Mail Delivery and Outgoing Mail Delivery.